I was trying to Understand what these code is doing.especially func reverse_binary_value().
I have read about Variadic functions? but cant understand why while returning Value the left shift 1 is done.
I got these code on hackerank. The question is something like this
Create a template function named reversed_binary_value. It must take an arbitrary number of bool values as template parameters. These booleans represent binary digits in reverse order. Your function must return an integer corresponding to the binary value of the digits represented by the booleans. For example: reversed_binary_value<0,0,1>() should return 4.
Input Format
he first line contains an integer, , the number of test cases. Each of the subsequent lines contains a test case. A test case is described as space-separated integers, and , respectively.
x is the value to compare against.
y represents the range to compare:64*y to 64*y+63
Output Format
Each line of output contains 64 binary characters.(i.e., 0's and 1's). Each character represents one value in the range.The first character corresponds to the first value in the range. The last character corresponds to the last value in the range. The character is 1 if the value in the range matches X ; otherwise, the character is 0.
Sample Input
2 65 1 10 0
sample Output 0100000000000000000000000000000000000000000000000000000000000000 0000000000100000000000000000000000000000000000000000000000000000
#include <iostream>
using namespace std;
template <bool a> int reversed_binary_value() { return a; }
template <bool a, bool b, bool... d> int reversed_binary_value() {
return (reversed_binary_value<b, d...>() << 1) + a;
}
template <int n, bool...digits>
struct CheckValues {
static void check(int x, int y)
{
CheckValues<n-1, 0, digits...>::check(x, y);
CheckValues<n-1, 1, digits...>::check(x, y);
}
};
template <bool...digits>
struct CheckValues<0, digits...> {
static void check(int x, int y)
{
int z = reversed_binary_value<digits...>();
std::cout << (z+64*y==x);
}
};
int main()
{
int t; std::cin >> t;
for (int i=0; i!=t; ++i) {
int x, y;
cin >> x >> y;
CheckValues<6>::check(x, y);
cout << "\n";
}
}
Aucun commentaire:
Enregistrer un commentaire